:::: MENU ::::

WebDevExp

Meine Erfahrungen in der Webentwicklerwelt

Posts Categorized / Webserver

  • Mrz 26 / 2014
  • 3
php, Webserver, Wordpress

WordPress sicherer – wp-admin und wp-login.php zusätzlich absichern – htaccess

Wie schon erwähnt betreibe ich diverse WordPress-Seiten in einer WP-Multisite-Installation.

Wichtigstes Plugin ist Wordfence-Security, welches nach veränderten Files sucht und Benutzer aussperrt (auf IP-Adressen-Ebene), falls es zuviele fehlgeschlagene Login-Versucht gibt. Da sich die „Aussperrungen“ in letzter Zeit häuften (Bruteforce-Attacken aus Fernost), wollte ich das ganze ein wenig „sicherer“ gestalten. Also entschied ich mich, die Zugriffe auf /wp-login.php und /wp-admin via Browser-Authentification (den meisten als „htaccess“ bekannt) zu sperren. Dies bietet sich in meinem Fall besonders an, da ich nur zwei aktive Nutzer der Backends habe. Wichtig: das ganze macht nur Sinn, wenn die htaccess-Zugangsdaten nicht denen des WordPress-Backends entsprechen. Continue Reading

  • Okt 06 / 2013
  • 0
Linux allgemein, Webserver

Yahoo akzeptiert meine E-Mails nicht

Mein privater Server wird, neben dem Hosting einiger Webseiten/Blogs, auch für den E-Mail-Empfang und -Versand genutzt. Bisher klappte das ziemlich gut und durch diverse Anti-Spam Maßnahmen, bin ich bisher weder im Spamordner meiner Empfänger gelandet, noch bekomme ich extrem viel Spam. Nun habe ich mich gewundert, dass eine Mail an einen Bekannten (***@yahoo.com) nicht zugestellt wurde, Begründung laut log:
postfix/smtp[30458]: 93DE398058A: to=<***@yahoo.de>, relay=mx-eu.mail.am0.yahoodns.net[188.125.69.79]:25, delay=139000, delays=138999/0.07/0.43/0, dsn=4.7.1, status=deferred (host mx-eu.mail.am0.yahoodns.net[188.125.69.79] refused to talk to me: 421 4.7.1 [TS03] All messages from 178.238.228.114 will be permanently deferred; Retrying will NOT succeed. See http://postmaster.yahoo.com/errors/421-ts03.html)

Continue Reading

  • Mrz 07 / 2013
  • 1
Allgemein, Webserver

Thunderbird Autokonfiguration für die eigene Domain

Ihr kennt das, ihr betreibt einen eigenen E-Mail-Server und bei jedem Einrichten eines Postfachs im E-Mail-Client eures Vertrauens, dürft ihr SMTP/IMAP Adresse, sowie SSL/TLS Einstellungen von Hand vornehmen, weil Thundebird diese Daten nicht automatisch ermitteln kann (bzw. es versucht, es aber meistens nicht stimmt, spätestens beim Format des Usernames).

Thunderbird bietet die Möglichkeit, unter der Domain „autoconfig.domain.de“ eine XML Datei unter dem Pfad /mail/config-v1.1.xml, für genau diese Einstellungen anzulegen. Andere Mail-Client beachten diese Datei mittlerweile auch (fragt mich bitte nicht welche).

Continue Reading

  • Aug 24 / 2010
  • 0
Webserver

lighttpd: Alle Subdomains auf www.domain.tld umleiten

Ich stand vor kurzem vor dem Problem, das alle Subdomains, die ein Benutzer eingeben könnte, auf www.example.com umleiten sollten.

Aus Googlesicht ist das gut, weil so doppelter Inhalt vermieden wird und für den Benutzer ist es einfach schöner.

Im Internet habe ich einige Beispiele gefunden, wie man www.example.com auf example.com und umgekehrt umleitet, aber keine generelle Lösung. Die Hostdefinition matcht *example.com und *.example.de, weitere sind ohne weiteres möglich.

Continue Reading

  • Jun 15 / 2009
  • 2
Linux allgemein, Webserver

APC statt eaccelerator oder XCache

Lange plagten wir uns mit dem Problem, dass die Webserver nach ein paar Tagen Betrieb 500er warfen (500 – Internal Server Error). Dies ging dann ein paar Sekunden so (nur 2-3) und danach lief alles wieder glatt. Das ganze passierte wahllos mal auf diesem, mal auf einem anderen Webserver. Continue Reading

  • Nov 07 / 2008
  • 4
Webserver

lighttpd restart Probleme

Setzt man auf einem Webserver sehr viele php-cgi Prozesse ein (allerdings nur mit einem Thread, da der eaccelerator sonst verrückt spielt), gibt es unter hoher Last diverse Probleme beim einfachen /etc/init.d/lighttpd restart
Continue Reading

  • Okt 25 / 2008
  • 0
php, Webserver

PHP 5.2.6 und eAccelerator 0.9.5.3

WIr nutzen diese Konstellation schon recht lange, doch seit ein paar Wochen, meint ein Teil der Webserver plötzlich nur noch 500er Fehler auszuspucken. Nach einem stoppen des Lighty, killen der übrigen php-cgi Prozesse, leeren des eAccelerator Caches und starten des Lighty, lief alles wieder einwandfrei.

Continue Reading

Seiten:12